Email Delays

Incident Report for TeamSideline.com

Resolved

Delayed communications are processing normally. We have continued monitoring the system, and service is stable.
Posted Jul 02, 2026 - 05:52 PDT

Investigating

You may experience brief delays in communications at this time.
Posted Jul 01, 2026 - 21:58 PDT
This incident affected: Communications.